FANDOM


This Forum has been archived

Visit the new Forums
Forums: Index World of Warcraft Backtracking help, please

Please put your content below here.

I'm in Zul'drak with my Tauran Druid. I took on the quest "Our Only Hope" which involves riding a giant to destroy other mobs. I cocked it up. Now the giant is in a cage and to get him out I have to repeat a couple of quests I've previously completed. But because I've completed the quests the mobs don't drop the materials I need to make progress.

Anyone advise me how to get out of this and uncomplete these previous quests? I've tried the quest log, but they've disappeared from it. 

This enquiring mind would like to know.


--77.100.236.13 21:06, July 18, 2014 (UTC)

There's no way to "undo" turning in a quest. There are plenty of times, however, where quests will glitch for whatever reason. Assuming you've tried waiting for a bit for it to reset on its own, I'd suggest putting in an in-game ticket. GMs can manually reset a glitched quest. Raylan13@fandom (talk) 22:31, July 18, 2014 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.